E: Sub-process /usr/bin/dpkg returned an error code (1)

Submitted by Anonymous (not verified) on Thu, 03/24/2011 - 21:28

I have a debian 64 bit lenny4 server and wanted to updatebind 9. Update is failed while I was trying with this commands:

apt-get -y install bind9
apt-get -y -f install bind9

I get this error at the end of shell window:
E: Sub-process /usr/bin/dpkg returned an error code (1)

This is the full output:

apt-get -y -f install bind9
Reading package lists... Done
Building dependency tree
Reading state information... Done
bind9 is already the newest version.
bind9 set to manually installed.
The following packages were automatically installed and are no longer required:
  libdns45 libisccc40 liblwres40 libbind9-40 libisccfg40 libisc45
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up mtop (0.6.6-1.2) ...
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
dpkg: error processing mtop (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
mtop
E: Sub-process /usr/bin/dpkg returned an error code (1)

Add new comment